Back to overview
Degraded
Minecraft Backend Servers
Jun 13, 2025 at 11:08am UTC
Affected services
General Minecraft Servers Systems
Resolved
Jun 13, 2025 at 11:15am UTC
The Issue has been resolved
Affected services
Created
Jun 13, 2025 at 11:08am UTC
We are currently looking into this alert. More information will be released soon.
Affected services