Back to overview
Downtime

Due to a severe thunderstorm, some services will be unavailable.

Nov 14 at 10:18pm AEST
Affected services
ECServers Main CDN
ECServers Dashboard
Login
Register
Creating Servers
Minecraft Servers
Backups
Payment
Uploading Files
Creating Servers Backend

Resolved
Nov 15 at 09:12am AEST

All services are online, you will be credited for this downtime from our SLA policy.

Created
Nov 14 at 10:18pm AEST

ECServers is currently offline due to a sudden NBN outage impacting our upstream connection. We’re in contact with our provider, and 3rd party services to restore the connection. Once NBN service is restored, all ECServers systems will come back online automatically. We’ll provide updates here as they become available.

If services don't automatically restore, are backup network systems will be activated from 7:00PM AEST tomorrow.