Back to overview
Downtime

Third Party Distruption

Dec 4, 2025 at 3:30am UTC
Affected services
ECServers Main CDN
ECServers Dashboard
Login
Register
Creating Servers
General Minecraft Servers Systems
Backups
Uploading Files
Creating Servers Backend

Resolved
Dec 4, 2025 at 6:18am UTC

We have confirmed all the issues have been fixed. Everything is back to operational. We are extremely sorry for the downtime.

Updated
Dec 4, 2025 at 5:11am UTC

Our backend is now not responding, we are investigating the issue currently.

Created
Dec 4, 2025 at 3:30am UTC

Our DDOS protection provider Is currently having issues surrounding routing to AU services. We are working to get services restored as soon as possible.