Control Panel Unavailable
Resolved
Jan 6, 2026 at 11:30pm UTC
The issue has been resolved.
Affected services
Updated
Jan 6, 2026 at 8:57pm UTC
Services are estimated to be restored in the next 2 and a half hours from now.
Affected services
Created
Jan 6, 2026 at 11:33am UTC
Their is currently a network issue from NBN affecting our control panel, and website servers. All game servers are unaffected.
Affected services